<!DOCTYPE html>
<html lang="en-US" class="no-js">
<head>
	<meta charset="UTF-8">
	<meta name="viewport" content="width=device-width, initial-scale=1">
	<link rel="profile" href="http://gmpg.org/xfn/11">
		<link rel="pingback" href="http://diecast-dude.com/xmlrpc.php">
		<script>(function(html){html.className = html.className.replace(/\bno-js\b/,'js')})(document.documentElement);</script>
<title>The Post I Hope I Never Have To Write &#8211; The Diecast Dude&#039;s (Mostly) NASCAR Blah Blah Blog</title>
<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="The Diecast Dude&#039;s (Mostly) NASCAR Blah Blah Blog &raquo; Feed" href="http://diecast-dude.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Diecast Dude&#039;s (Mostly) NASCAR Blah Blah Blog &raquo; Comments Feed" href="http://diecast-dude.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Diecast Dude&#039;s (Mostly) NASCAR Blah Blah Blog &raquo; The Post I Hope I Never Have To Write Comments Feed" href="http://diecast-dude.com/2020/02/18/the-post-i-hope-i-never-have-to-write/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/diecast-dude.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.2"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='twentysixteen-jetpack-css'  href='http://diecast-dude.com/wp-content/plugins/jetpack/modules/theme-tools/compat/twentysixteen.css?ver=8.2.3' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='http://diecast-dude.com/wp-includes/css/dist/block-library/style.min.css?ver=5.3.2' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='wp-block-library-theme-css'  href='http://diecast-dude.com/wp-includes/css/dist/block-library/theme.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='bg-shce-genericons-css'  href='http://diecast-dude.com/wp-content/plugins/show-hidecollapse-expand/assets/css/genericons/genericons.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='bg-show-hide-css'  href='http://diecast-dude.com/wp-content/plugins/show-hidecollapse-expand/assets/css/bg-show-hide.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='twentysixteen-fonts-css'  href='https://fonts.googleapis.com/css?family=Merriweather%3A400%2C700%2C900%2C400italic%2C700italic%2C900italic%7CMontserrat%3A400%2C700%7CInconsolata%3A400&#038;subset=latin%2Clatin-ext' type='text/css' media='all' />
<link rel='stylesheet' id='genericons-css'  href='http://diecast-dude.com/wp-content/plugins/jetpack/_inc/genericons/genericons/genericons.css?ver=3.1' type='text/css' media='all' />
<link rel='stylesheet' id='twentysixteen-style-css'  href='http://diecast-dude.com/wp-content/themes/twentysixteen/style.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='twentysixteen-block-style-css'  href='http://diecast-dude.com/wp-content/themes/twentysixteen/css/blocks.css?ver=20181230' type='text/css' media='all' />
<!--[if lt IE 10]>
<link rel='stylesheet' id='twentysixteen-ie-css'  href='http://diecast-dude.com/wp-content/themes/twentysixteen/css/ie.css?ver=20160816' type='text/css' media='all' />
<![endif]-->
<!--[if lt IE 9]>
<link rel='stylesheet' id='twentysixteen-ie8-css'  href='http://diecast-dude.com/wp-content/themes/twentysixteen/css/ie8.css?ver=20160816' type='text/css' media='all' />
<![endif]-->
<!--[if lt IE 8]>
<link rel='stylesheet' id='twentysixteen-ie7-css'  href='http://diecast-dude.com/wp-content/themes/twentysixteen/css/ie7.css?ver=20160816' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='social-logos-css'  href='http://diecast-dude.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://diecast-dude.com/wp-content/plugins/jetpack/css/jetpack.css?ver=8.2.3' type='text/css' media='all' />
<script type='text/javascript' src='http://diecast-dude.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='http://diecast-dude.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='http://diecast-dude.com/wp-content/plugins/jetpack/_inc/build/related-posts/related-posts.min.js?ver=20191011'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='http://diecast-dude.com/wp-content/themes/twentysixteen/js/html5.js?ver=3.7.3'></script>
<![endif]-->
<link rel='https://api.w.org/' href='http://diecast-dude.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://diecast-dude.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://diecast-dude.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Of All The Times To Be Sick &#8230;' href='http://diecast-dude.com/2020/02/14/of-all-the-times-to-be-sick/' />
<link rel='next' title='Photo Of The Year' href='http://diecast-dude.com/2020/02/19/photo-of-the-year/' />
<meta name="generator" content="WordPress 5.3.2" />
<link rel="canonical" href="http://diecast-dude.com/2020/02/18/the-post-i-hope-i-never-have-to-write/" />
<link rel='shortlink' href='https://wp.me/p6VatS-v7' />
<link rel="alternate" type="application/json+oembed" href="http://diecast-dude.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fdiecast-dude.com%2F2020%2F02%2F18%2Fthe-post-i-hope-i-never-have-to-write%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://diecast-dude.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fdiecast-dude.com%2F2020%2F02%2F18%2Fthe-post-i-hope-i-never-have-to-write%2F&#038;format=xml" />

<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<link rel='dns-prefetch' href='//i0.wp.com'/>
<link rel='dns-prefetch' href='//i1.wp.com'/>
<link rel='dns-prefetch' href='//i2.wp.com'/>
<style type='text/css'>img#wpstats{display:none}</style><style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style>
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="The Post I Hope I Never Have To Write" />
<meta property="og:url" content="http://diecast-dude.com/2020/02/18/the-post-i-hope-i-never-have-to-write/" />
<meta property="og:description" content="Growing up, my favorite sportswriter was Jim Murray. Most of his columns were supremely funny. When the moment required otherwise, he could stop your heart with achingly beautiful words. One such c…" />
<meta property="article:published_time" content="2020-02-19T05:04:00+00:00" />
<meta property="article:modified_time" content="2020-02-19T05:04:00+00:00" />
<meta property="og:site_name" content="The Diecast Dude&#039;s (Mostly) NASCAR Blah Blah Blog" />
<meta property="og:image" content="https://i0.wp.com/diecast-dude.com/wp-content/uploads/2020/02/DIS1_NCS_TeamCelebration_021720.jpg?fit=600%2C400" />
<meta property="og:image:width" content="600" />
<meta property="og:image:height" content="400" />
<meta property="og:image:alt" content="Chris Graythen | Getty Images" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:creator" content="@DiecastDude" />
<meta name="twitter:text:title" content="The Post I Hope I Never Have To Write" />
<meta name="twitter:image" content="https://i0.wp.com/diecast-dude.com/wp-content/uploads/2020/02/DIS1_NCS_TeamCelebration_021720.jpg?fit=600%2C400&#038;w=640" />
<meta name="twitter:image:alt" content="Chris Graythen | Getty Images" />
<meta name="twitter:card" content="summary_large_image" />

<!-- End Jetpack Open Graph Tags -->
<link rel="icon" href="https://i1.wp.com/diecast-dude.com/wp-content/uploads/2020/01/cropped-Untitled-1-1.png?fit=32%2C32" sizes="32x32" />
<link rel="icon" href="https://i1.wp.com/diecast-dude.com/wp-content/uploads/2020/01/cropped-Untitled-1-1.png?fit=192%2C192" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://i1.wp.com/diecast-dude.com/wp-content/uploads/2020/01/cropped-Untitled-1-1.png?fit=180%2C180" />
<meta name="msapplication-TileImage" content="https://i1.wp.com/diecast-dude.com/wp-content/uploads/2020/01/cropped-Untitled-1-1.png?fit=270%2C270" />
</head>

<body class="post-template-default single single-post postid-1929 single-format-standard wp-embed-responsive">
<div id="page" class="site">
	<div class="site-inner">
		<a class="skip-link screen-reader-text" href="#content">Skip to content</a>

		<header id="masthead" class="site-header" role="banner">
			<div class="site-header-main">
				<div class="site-branding">
					
											<p class="site-title"><a href="http://diecast-dude.com/" rel="home">The Diecast Dude&#039;s (Mostly) NASCAR Blah Blah Blog</a></p>
												<p class="site-description">Bringing NASCAR blogging back since right now.</p>
									</div><!-- .site-branding -->

							</div><!-- .site-header-main -->

					</header><!-- .site-header -->

		<div id="content" class="site-content">

<div id="primary" class="content-area">
	<main id="main" class="site-main" role="main">
		
<article id="post-1929" class="post-1929 post type-post status-publish format-standard has-post-thumbnail hentry category-nascar-cup-series tag-2020-daytona-500 tag-denny-hamlin tag-ryan-newman">
	<header class="entry-header">
		<h1 class="entry-title">The Post I Hope I Never Have To Write</h1>	</header><!-- .entry-header -->

	
	
		<div class="post-thumbnail">
			<img width="600" height="400" src="https://i0.wp.com/diecast-dude.com/wp-content/uploads/2020/02/DIS1_NCS_TeamCelebration_021720.jpg?fit=600%2C400" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="Chris Graythen | Getty Images" srcset="https://i0.wp.com/diecast-dude.com/wp-content/uploads/2020/02/DIS1_NCS_TeamCelebration_021720.jpg?w=600 600w, https://i0.wp.com/diecast-dude.com/wp-content/uploads/2020/02/DIS1_NCS_TeamCelebration_021720.jpg?resize=300%2C200 300w" sizes="(max-width: 709px) 85vw, (max-width: 909px) 67vw, (max-width: 984px) 60vw, (max-width: 1362px) 62vw, 840px" data-attachment-id="1931" data-permalink="http://diecast-dude.com/dis1_ncs_teamcelebration_021720/" data-orig-file="https://i0.wp.com/diecast-dude.com/wp-content/uploads/2020/02/DIS1_NCS_TeamCelebration_021720.jpg?fit=600%2C400" data-orig-size="600,400" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Chris Graythen | Getty Images" data-image-description="&lt;p&gt;Chris Graythen | Getty Images&lt;/p&gt;
" data-medium-file="https://i0.wp.com/diecast-dude.com/wp-content/uploads/2020/02/DIS1_NCS_TeamCelebration_021720.jpg?fit=300%2C200" data-large-file="https://i0.wp.com/diecast-dude.com/wp-content/uploads/2020/02/DIS1_NCS_TeamCelebration_021720.jpg?fit=600%2C400" />	</div><!-- .post-thumbnail -->

	
	<div class="entry-content">
		<p>Growing up, my favorite sportswriter was Jim Murray. Most of his columns were supremely funny. When the moment required otherwise, he could stop your heart with achingly beautiful words.</p>
<p>One such column by him I remember was the one he wrote after his wife passed away. It&#8217;s been decades since I&#8217;ve read it, thus quoting it accurately is not an option. That said, as best I remember it started with him saying this was the column he hoped he&#8217;d never have to write.</p>
<p>That phrase came to mind yesterday after listening to the conclusion of the Daytona 500 (it ended a few minutes after I got off work), then frantically refreshing my Twitter feed hoping for some word of Ryan Newman&#8217;s condition. I watched the clip of the accident, Newman&#8217;s car going airborne and landing on its roof after a bump pass gone awry, then unavoidably slammed into at full speed by Cory LaJoie. I watched it once and once only. I couldn&#8217;t watch it again. And I dreaded having to think about the post I hope I never have to write. Thank God (literally) I don&#8217;t have to.</p>
<p>Now that we know Newman is at least alive, although details of his condition remain unknown save to those directly involved, it&#8217;s fair to comment on the race itself. By any other name, restrictor plate racing remains a gladiatorial event as far removed from actual racing as Greta Van Fleet is from Led Zeppelin. There is no way to make it safe, or enjoyable, or acceptable. None. It is an abomination deserving to be forever banished from NASCAR. Even with all the heralded advances in safety the past nearly two decades, it damn near killed Ryan Newman yesterday. Yes, it is impossible to make racing completely safe. However, when you have a format virtually guaranteeing one or more multi-car disasters, it&#8217;s entirely fair to dismiss said format as something worthy of continuation.</p>
<p>Lost in the above was some deft driving by Denny Hamlin to take the win, and the hope Ryan Blaney can sufficiently block out the voices screaming he was at fault for what happened to Newman to maintain the necessary focus and aggression needed to be a successful driver.</p>
<p>Here&#8217;s hoping for a much tamer Las Vegas this coming weekend.</p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-1929" class="share-twitter sd-button share-icon no-text" href="http://diecast-dude.com/2020/02/18/the-post-i-hope-i-never-have-to-write/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-1929" class="share-facebook sd-button share-icon no-text" href="http://diecast-dude.com/2020/02/18/the-post-i-hope-i-never-have-to-write/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div>	</div><!-- .entry-content -->

	<footer class="entry-footer">
		<span class="byline"><span class="author vcard"><img alt='' src='http://2.gravatar.com/avatar/21a01650551218b55097c86f22e23160?s=49&#038;d=mm&#038;r=g' srcset='http://2.gravatar.com/avatar/21a01650551218b55097c86f22e23160?s=98&#038;d=mm&#038;r=g 2x' class='avatar avatar-49 photo' height='49' width='49' /><span class="screen-reader-text">Author </span> <a class="url fn n" href="http://diecast-dude.com/author/jerrywilson/">Diecast Dude</a></span></span><span class="posted-on"><span class="screen-reader-text">Posted on </span><a href="http://diecast-dude.com/2020/02/18/the-post-i-hope-i-never-have-to-write/" rel="bookmark"><time class="entry-date published updated" datetime="2020-02-18T21:04:00-08:00">February 18, 2020</time></a></span><span class="cat-links"><span class="screen-reader-text">Categories </span><a href="http://diecast-dude.com/category/nascar-cup-series/" rel="category tag">NASCAR Cup Series</a></span><span class="tags-links"><span class="screen-reader-text">Tags </span><a href="http://diecast-dude.com/tag/2020-daytona-500/" rel="tag">2020 Daytona 500</a>, <a href="http://diecast-dude.com/tag/denny-hamlin/" rel="tag">Denny Hamlin</a>, <a href="http://diecast-dude.com/tag/ryan-newman/" rel="tag">Ryan Newman</a></span>			</footer><!-- .entry-footer -->
</article><!-- #post-1929 -->

	<nav class="navigation post-navigation" role="navigation" aria-label="Posts">
		<h2 class="screen-reader-text">Post navigation</h2>
		<div class="nav-links"><div class="nav-previous"><a href="http://diecast-dude.com/2020/02/14/of-all-the-times-to-be-sick/" rel="prev"><span class="meta-nav" aria-hidden="true">Previous</span> <span class="screen-reader-text">Previous post:</span> <span class="post-title">Of All The Times To Be Sick &#8230;</span></a></div><div class="nav-next"><a href="http://diecast-dude.com/2020/02/19/photo-of-the-year/" rel="next"><span class="meta-nav" aria-hidden="true">Next</span> <span class="screen-reader-text">Next post:</span> <span class="post-title">Photo Of The Year</span></a></div></div>
	</nav>
	</main><!-- .site-main -->

	
</div><!-- .content-area -->


	<aside id="secondary" class="sidebar widget-area" role="complementary">
		<section id="pages-3" class="widget widget_pages"><h2 class="widget-title">Pages</h2>		<ul>
			<li class="page_item page-item-397 page_item_has_children"><a href="http://diecast-dude.com/2020-nascar-schedule/">2020 NASCAR Schedule</a>
<ul class='children'>
	<li class="page_item page-item-399"><a href="http://diecast-dude.com/2020-nascar-schedule/nascar-cup-series/">NASCAR Cup Series</a></li>
	<li class="page_item page-item-401"><a href="http://diecast-dude.com/2020-nascar-schedule/nascar-xfinity-series/">NASCAR Xfinity Series</a></li>
	<li class="page_item page-item-406"><a href="http://diecast-dude.com/2020-nascar-schedule/nascar-gander-rv-outdoors-truck-series/">NASCAR Gander RV &#038; Outdoors Truck Series</a></li>
</ul>
</li>
<li class="page_item page-item-2"><a href="http://diecast-dude.com/nascar-news/">NASCAR News</a></li>
<li class="page_item page-item-156 page_item_has_children"><a href="http://diecast-dude.com/nascar-cup-series/">NASCAR Cup Series</a>
<ul class='children'>
	<li class="page_item page-item-1265 page_item_has_children"><a href="http://diecast-dude.com/nascar-cup-series/2020-busch-clash-at-daytona/">2020 Busch Clash at Daytona</a>
	<ul class='children'>
		<li class="page_item page-item-167"><a href="http://diecast-dude.com/nascar-cup-series/2020-busch-clash-at-daytona/pre-race-info/">Pre-Race Info</a></li>
		<li class="page_item page-item-165"><a href="http://diecast-dude.com/nascar-cup-series/2020-busch-clash-at-daytona/post-race-info/">Post-Race Info</a></li>
	</ul>
</li>
	<li class="page_item page-item-1834 page_item_has_children"><a href="http://diecast-dude.com/nascar-cup-series/2020-daytona-500/">2020 Daytona 500</a>
	<ul class='children'>
		<li class="page_item page-item-1837"><a href="http://diecast-dude.com/nascar-cup-series/2020-daytona-500/pre-race-info/">Pre-Race Info</a></li>
		<li class="page_item page-item-1910"><a href="http://diecast-dude.com/nascar-cup-series/2020-daytona-500/post-race-info/">Post-Race Info</a></li>
	</ul>
</li>
	<li class="page_item page-item-1922 page_item_has_children"><a href="http://diecast-dude.com/nascar-cup-series/2020-pennzoil-400-presented-by-jiffy-lube/">2020 Pennzoil 400 Presented by Jiffy Lube</a>
	<ul class='children'>
		<li class="page_item page-item-1925"><a href="http://diecast-dude.com/nascar-cup-series/2020-pennzoil-400-presented-by-jiffy-lube/pre-race-info/">Pre-Race Info</a></li>
	</ul>
</li>
</ul>
</li>
<li class="page_item page-item-161 page_item_has_children"><a href="http://diecast-dude.com/nascar-xfinity-series/">NASCAR Xfinity Series</a>
<ul class='children'>
	<li class="page_item page-item-1905 page_item_has_children"><a href="http://diecast-dude.com/nascar-xfinity-series/2020-nascar-racing-experience-300/">2020 NASCAR Racing Experience 300</a>
	<ul class='children'>
		<li class="page_item page-item-172"><a href="http://diecast-dude.com/nascar-xfinity-series/2020-nascar-racing-experience-300/pre-race-info/">Pre-Race Info</a></li>
		<li class="page_item page-item-174"><a href="http://diecast-dude.com/nascar-xfinity-series/2020-nascar-racing-experience-300/post-race-info/">Post-Race Info</a></li>
	</ul>
</li>
	<li class="page_item page-item-1971 page_item_has_children"><a href="http://diecast-dude.com/nascar-xfinity-series/2020-boyd-gaming-300/">2020 Boyd Gaming 300</a>
	<ul class='children'>
		<li class="page_item page-item-1973"><a href="http://diecast-dude.com/nascar-xfinity-series/2020-boyd-gaming-300/pre-race-info/">Pre-Race Info</a></li>
	</ul>
</li>
</ul>
</li>
<li class="page_item page-item-163 page_item_has_children"><a href="http://diecast-dude.com/nascar-gander-rv-outdoors-truck-series/">NASCAR Gander RV &#038; Outdoors Truck Series</a>
<ul class='children'>
	<li class="page_item page-item-1901 page_item_has_children"><a href="http://diecast-dude.com/nascar-gander-rv-outdoors-truck-series/2020-nextera-energy-250/">2020 NextEra Energy 250</a>
	<ul class='children'>
		<li class="page_item page-item-176"><a href="http://diecast-dude.com/nascar-gander-rv-outdoors-truck-series/2020-nextera-energy-250/pre-race-info/">Pre-Race Info</a></li>
		<li class="page_item page-item-178"><a href="http://diecast-dude.com/nascar-gander-rv-outdoors-truck-series/2020-nextera-energy-250/post-race-info/">Post-Race Info</a></li>
	</ul>
</li>
	<li class="page_item page-item-1978 page_item_has_children"><a href="http://diecast-dude.com/nascar-gander-rv-outdoors-truck-series/2020-the-strat-200/">2020 The Strat 200</a>
	<ul class='children'>
		<li class="page_item page-item-1980"><a href="http://diecast-dude.com/nascar-gander-rv-outdoors-truck-series/2020-the-strat-200/pre-race-info/">Pre-Race Info</a></li>
	</ul>
</li>
</ul>
</li>
<li class="page_item page-item-183 page_item_has_children"><a href="http://diecast-dude.com/drivers/">Drivers</a>
<ul class='children'>
	<li class="page_item page-item-185 page_item_has_children"><a href="http://diecast-dude.com/drivers/nascar-cup-series/">NASCAR Cup Series</a>
	<ul class='children'>
		<li class="page_item page-item-306"><a href="http://diecast-dude.com/drivers/nascar-cup-series/aric-almirola/">Aric Almirola</a></li>
		<li class="page_item page-item-308"><a href="http://diecast-dude.com/drivers/nascar-cup-series/christopher-bell/">Christopher Bell</a></li>
		<li class="page_item page-item-310"><a href="http://diecast-dude.com/drivers/nascar-cup-series/ryan-blaney/">Ryan Blaney</a></li>
		<li class="page_item page-item-312"><a href="http://diecast-dude.com/drivers/nascar-cup-series/alex-bowman/">Alex Bowman</a></li>
		<li class="page_item page-item-314"><a href="http://diecast-dude.com/drivers/nascar-cup-series/clint-bowyer/">Clint Bowyer</a></li>
		<li class="page_item page-item-316"><a href="http://diecast-dude.com/drivers/nascar-cup-series/chris-buescher/">Chris Buescher</a></li>
		<li class="page_item page-item-321"><a href="http://diecast-dude.com/drivers/nascar-cup-series/kurt-busch/">Kurt Busch</a></li>
		<li class="page_item page-item-323"><a href="http://diecast-dude.com/drivers/nascar-cup-series/kyle-busch/">Kyle Busch</a></li>
		<li class="page_item page-item-325"><a href="http://diecast-dude.com/drivers/nascar-cup-series/william-byron/">William Byron</a></li>
		<li class="page_item page-item-327"><a href="http://diecast-dude.com/drivers/nascar-cup-series/cole-custer/">Cole Custer</a></li>
		<li class="page_item page-item-329"><a href="http://diecast-dude.com/drivers/nascar-cup-series/matt-dibenedetto/">Matt DiBenedetto</a></li>
		<li class="page_item page-item-331"><a href="http://diecast-dude.com/drivers/nascar-cup-series/austin-dillon/">Austin Dillon</a></li>
		<li class="page_item page-item-333"><a href="http://diecast-dude.com/drivers/nascar-cup-series/ty-dillon/">Ty Dillon</a></li>
		<li class="page_item page-item-335"><a href="http://diecast-dude.com/drivers/nascar-cup-series/chase-elliott/">Chase Elliott</a></li>
		<li class="page_item page-item-340"><a href="http://diecast-dude.com/drivers/nascar-cup-series/joey-gase/">Joey Gase</a></li>
		<li class="page_item page-item-194"><a href="http://diecast-dude.com/drivers/nascar-cup-series/brendan-gaughan/">Brendan Gaughan</a></li>
		<li class="page_item page-item-342"><a href="http://diecast-dude.com/drivers/nascar-cup-series/denny-hamlin/">Denny Hamlin</a></li>
		<li class="page_item page-item-347"><a href="http://diecast-dude.com/drivers/nascar-cup-series/kevin-harvick/">Kevin Harvick</a></li>
		<li class="page_item page-item-349"><a href="http://diecast-dude.com/drivers/nascar-cup-series/quin-houff/">Quin Houff</a></li>
		<li class="page_item page-item-351"><a href="http://diecast-dude.com/drivers/nascar-cup-series/jimmie-johnson/">Jimmie Johnson</a></li>
		<li class="page_item page-item-355"><a href="http://diecast-dude.com/drivers/nascar-cup-series/brad-keselowski/">Brad Keselowski</a></li>
		<li class="page_item page-item-353"><a href="http://diecast-dude.com/drivers/nascar-cup-series/erik-jones/">Erik Jones</a></li>
		<li class="page_item page-item-357"><a href="http://diecast-dude.com/drivers/nascar-cup-series/parker-kligerman/">Parker Kligerman</a></li>
		<li class="page_item page-item-359"><a href="http://diecast-dude.com/drivers/nascar-cup-series/corey-lajoie/">Corey LaJoie</a></li>
		<li class="page_item page-item-361"><a href="http://diecast-dude.com/drivers/nascar-cup-series/kyle-larson/">Kyle Larson</a></li>
		<li class="page_item page-item-366"><a href="http://diecast-dude.com/drivers/nascar-cup-series/joey-logano/">Joey Logano</a></li>
		<li class="page_item page-item-368"><a href="http://diecast-dude.com/drivers/nascar-cup-series/bj-mcleod/">BJ McLeod</a></li>
		<li class="page_item page-item-370"><a href="http://diecast-dude.com/drivers/nascar-cup-series/michael-mcdowell/">Michael McDowell</a></li>
		<li class="page_item page-item-372"><a href="http://diecast-dude.com/drivers/nascar-cup-series/john-hunter-nemechek/">John Hunter Nemechek</a></li>
		<li class="page_item page-item-377"><a href="http://diecast-dude.com/drivers/nascar-cup-series/ryan-newman/">Ryan Newman</a></li>
		<li class="page_item page-item-379"><a href="http://diecast-dude.com/drivers/nascar-cup-series/brennan-poole/">Brennan Poole</a></li>
		<li class="page_item page-item-381"><a href="http://diecast-dude.com/drivers/nascar-cup-series/ryan-preece/">Ryan Preece</a></li>
		<li class="page_item page-item-383"><a href="http://diecast-dude.com/drivers/nascar-cup-series/tyler-reddick/">Tyler Reddick</a></li>
		<li class="page_item page-item-385"><a href="http://diecast-dude.com/drivers/nascar-cup-series/ricky-stenhouse-jr/">Ricky Stenhouse Jr.</a></li>
		<li class="page_item page-item-682"><a href="http://diecast-dude.com/drivers/nascar-cup-series/daniel-suarez/">Daniel Suárez</a></li>
		<li class="page_item page-item-387"><a href="http://diecast-dude.com/drivers/nascar-cup-series/martin-truex-jr/">Martin Truex Jr.</a></li>
		<li class="page_item page-item-389"><a href="http://diecast-dude.com/drivers/nascar-cup-series/bubba-wallace/">Bubba Wallace</a></li>
		<li class="page_item page-item-391"><a href="http://diecast-dude.com/drivers/nascar-cup-series/j-j-yeley/">J.J. Yeley</a></li>
	</ul>
</li>
	<li class="page_item page-item-187 page_item_has_children"><a href="http://diecast-dude.com/drivers/nascar-xfinity-series/">NASCAR Xfinity Series</a>
	<ul class='children'>
		<li class="page_item page-item-1616"><a href="http://diecast-dude.com/drivers/nascar-xfinity-series/anthony-alfredo/">Anthony Alfredo</a></li>
		<li class="page_item page-item-1618"><a href="http://diecast-dude.com/drivers/nascar-xfinity-series/justin-allgaier/">Justin Allgaier</a></li>
		<li class="page_item page-item-1620"><a href="http://diecast-dude.com/drivers/nascar-xfinity-series/michael-annett/">Michael Annett</a></li>
		<li class="page_item page-item-1622"><a href="http://diecast-dude.com/drivers/nascar-xfinity-series/spencer-boyd/">Spencer Boyd</a></li>
		<li class="page_item page-item-1624"><a href="http://diecast-dude.com/drivers/nascar-xfinity-series/chase-briscoe/">Chase Briscoe</a></li>
		<li class="page_item page-item-1626"><a href="http://diecast-dude.com/drivers/nascar-xfinity-series/brandon-brown/">Brandon Brown</a></li>
		<li class="page_item page-item-1628"><a href="http://diecast-dude.com/drivers/nascar-xfinity-series/harrison-burton/">Harrison Burton</a></li>
		<li class="page_item page-item-1630"><a href="http://diecast-dude.com/drivers/nascar-xfinity-series/jeb-burton/">Jeb Burton</a></li>
		<li class="page_item page-item-1632"><a href="http://diecast-dude.com/drivers/nascar-xfinity-series/ross-chastain/">Ross Chastain</a></li>
		<li class="page_item page-item-1634"><a href="http://diecast-dude.com/drivers/nascar-xfinity-series/austin-cindric/">Austin Cindric</a></li>
		<li class="page_item page-item-1636"><a href="http://diecast-dude.com/drivers/nascar-xfinity-series/jeremy-clements/">Jeremy Clements</a></li>
		<li class="page_item page-item-1638"><a href="http://diecast-dude.com/drivers/nascar-xfinity-series/dale-earnhardt-jr/">Dale Earnhardt Jr.</a></li>
		<li class="page_item page-item-1640"><a href="http://diecast-dude.com/drivers/nascar-xfinity-series/chad-finchum/">Chad Finchum</a></li>
		<li class="page_item page-item-1642"><a href="http://diecast-dude.com/drivers/nascar-xfinity-series/joe-graf-jr/">Joe Graf Jr.</a></li>
		<li class="page_item page-item-1644"><a href="http://diecast-dude.com/drivers/nascar-xfinity-series/noah-gragson/">Noah Gragson</a></li>
		<li class="page_item page-item-203"><a href="http://diecast-dude.com/drivers/nascar-xfinity-series/kaz-grala/">Kaz Grala</a></li>
		<li class="page_item page-item-1646"><a href="http://diecast-dude.com/drivers/nascar-xfinity-series/justin-haley/">Justin Haley</a></li>
		<li class="page_item page-item-1648"><a href="http://diecast-dude.com/drivers/nascar-xfinity-series/daniel-hemric/">Daniel Hemric</a></li>
		<li class="page_item page-item-1650"><a href="http://diecast-dude.com/drivers/nascar-xfinity-series/riley-herbst/">Riley Herbst</a></li>
		<li class="page_item page-item-1652"><a href="http://diecast-dude.com/drivers/nascar-xfinity-series/colby-howard/">Colby Howard</a></li>
		<li class="page_item page-item-1654"><a href="http://diecast-dude.com/drivers/nascar-xfinity-series/brandon-jones/">Brandon Jones</a></li>
		<li class="page_item page-item-1656"><a href="http://diecast-dude.com/drivers/nascar-xfinity-series/shane-lee/">Shane Lee</a></li>
		<li class="page_item page-item-1658"><a href="http://diecast-dude.com/drivers/nascar-xfinity-series/jesse-little/">Jesse Little</a></li>
		<li class="page_item page-item-1660"><a href="http://diecast-dude.com/drivers/nascar-xfinity-series/dylan-lupton/">Dylan Lupton</a></li>
		<li class="page_item page-item-1662"><a href="http://diecast-dude.com/drivers/nascar-xfinity-series/tommy-joe-martins/">Tommy Joe Martins</a></li>
		<li class="page_item page-item-1664"><a href="http://diecast-dude.com/drivers/nascar-xfinity-series/vinnie-miller/">Vinnie Miller</a></li>
		<li class="page_item page-item-1666"><a href="http://diecast-dude.com/drivers/nascar-xfinity-series/matt-mills/">Matt Mills</a></li>
		<li class="page_item page-item-1669"><a href="http://diecast-dude.com/drivers/nascar-xfinity-series/austin-wayne-self/">Austin Wayne Self</a></li>
		<li class="page_item page-item-1671"><a href="http://diecast-dude.com/drivers/nascar-xfinity-series/ryan-sieg/">Ryan Sieg</a></li>
		<li class="page_item page-item-1673"><a href="http://diecast-dude.com/drivers/nascar-xfinity-series/garrett-smithley/">Garrett Smithley</a></li>
		<li class="page_item page-item-1675"><a href="http://diecast-dude.com/drivers/nascar-xfinity-series/myatt-snider/">Myatt Snider</a></li>
		<li class="page_item page-item-1677"><a href="http://diecast-dude.com/drivers/nascar-xfinity-series/david-starr/">David Starr</a></li>
	</ul>
</li>
	<li class="page_item page-item-189 page_item_has_children"><a href="http://diecast-dude.com/drivers/nascar-gander-rv-outdoors-truck-series/">NASCAR Gander RV &#038; Outdoors Truck Series</a>
	<ul class='children'>
		<li class="page_item page-item-1679"><a href="http://diecast-dude.com/drivers/nascar-gander-rv-outdoors-truck-series/jordan-anderson/">Jordan Anderson</a></li>
		<li class="page_item page-item-1681"><a href="http://diecast-dude.com/drivers/nascar-gander-rv-outdoors-truck-series/tyler-ankrum/">Tyler Ankrum</a></li>
		<li class="page_item page-item-1683"><a href="http://diecast-dude.com/drivers/nascar-gander-rv-outdoors-truck-series/jennifer-jo-cobb/">Jennifer Jo Cobb</a></li>
		<li class="page_item page-item-1685"><a href="http://diecast-dude.com/drivers/nascar-gander-rv-outdoors-truck-series/matt-crafton/">Matt Crafton</a></li>
		<li class="page_item page-item-1687"><a href="http://diecast-dude.com/drivers/nascar-gander-rv-outdoors-truck-series/sheldon-creed/">Sheldon Creed</a></li>
		<li class="page_item page-item-1689"><a href="http://diecast-dude.com/drivers/nascar-gander-rv-outdoors-truck-series/natalie-decker/">Natalie Decker</a></li>
		<li class="page_item page-item-1691"><a href="http://diecast-dude.com/drivers/nascar-gander-rv-outdoors-truck-series/christian-eckes/">Christian Eckes</a></li>
		<li class="page_item page-item-1693"><a href="http://diecast-dude.com/drivers/nascar-gander-rv-outdoors-truck-series/grant-enfinger/">Grant Enfinger</a></li>
		<li class="page_item page-item-1695"><a href="http://diecast-dude.com/drivers/nascar-gander-rv-outdoors-truck-series/tate-fogleman/">Tate Fogleman</a></li>
		<li class="page_item page-item-1697"><a href="http://diecast-dude.com/drivers/nascar-gander-rv-outdoors-truck-series/stewart-friesen/">Stewart Friesen</a></li>
		<li class="page_item page-item-1699"><a href="http://diecast-dude.com/drivers/nascar-gander-rv-outdoors-truck-series/todd-gilliland/">Todd Gilliland</a></li>
		<li class="page_item page-item-1701"><a href="http://diecast-dude.com/drivers/nascar-gander-rv-outdoors-truck-series/david-gravel/">David Gravel</a></li>
		<li class="page_item page-item-1703"><a href="http://diecast-dude.com/drivers/nascar-gander-rv-outdoors-truck-series/tanner-gray/">Tanner Gray</a></li>
		<li class="page_item page-item-1705"><a href="http://diecast-dude.com/drivers/nascar-gander-rv-outdoors-truck-series/austin-hill/">Austin Hill</a></li>
		<li class="page_item page-item-1707"><a href="http://diecast-dude.com/drivers/nascar-gander-rv-outdoors-truck-series/derek-kraus/">Derek Kraus</a></li>
		<li class="page_item page-item-1709"><a href="http://diecast-dude.com/drivers/nascar-gander-rv-outdoors-truck-series/raphael-lessard/">Raphael Lessard</a></li>
		<li class="page_item page-item-1711"><a href="http://diecast-dude.com/drivers/nascar-gander-rv-outdoors-truck-series/ty-majeski/">Ty Majeski</a></li>
		<li class="page_item page-item-1713"><a href="http://diecast-dude.com/drivers/nascar-gander-rv-outdoors-truck-series/brett-moffitt/">Brett Moffitt</a></li>
		<li class="page_item page-item-1715"><a href="http://diecast-dude.com/drivers/nascar-gander-rv-outdoors-truck-series/joe-nemechek/">Joe Nemechek</a></li>
		<li class="page_item page-item-1717"><a href="http://diecast-dude.com/drivers/nascar-gander-rv-outdoors-truck-series/josh-reaume/">Josh Reaume</a></li>
		<li class="page_item page-item-1719"><a href="http://diecast-dude.com/drivers/nascar-gander-rv-outdoors-truck-series/ben-rhodes/">Ben Rhodes</a></li>
		<li class="page_item page-item-1721"><a href="http://diecast-dude.com/drivers/nascar-gander-rv-outdoors-truck-series/cory-roper/">Cory Roper</a></li>
		<li class="page_item page-item-1724"><a href="http://diecast-dude.com/drivers/nascar-gander-rv-outdoors-truck-series/angela-ruch/">Angela Ruch</a></li>
		<li class="page_item page-item-1726"><a href="http://diecast-dude.com/drivers/nascar-gander-rv-outdoors-truck-series/johnny-sauter/">Johnny Sauter</a></li>
		<li class="page_item page-item-1729"><a href="http://diecast-dude.com/drivers/nascar-gander-rv-outdoors-truck-series/zane-smith/">Zane Smith</a></li>
		<li class="page_item page-item-1731"><a href="http://diecast-dude.com/drivers/nascar-gander-rv-outdoors-truck-series/myatt-snider/">Myatt Snider</a></li>
	</ul>
</li>
</ul>
</li>
<li class="page_item page-item-209 page_item_has_children"><a href="http://diecast-dude.com/teams/">Teams</a>
<ul class='children'>
	<li class="page_item page-item-1734"><a href="http://diecast-dude.com/teams/acg-motorsports/">ACG Motorsports</a></li>
	<li class="page_item page-item-1736"><a href="http://diecast-dude.com/teams/am-racing/">AM Racing</a></li>
	<li class="page_item page-item-1738"><a href="http://diecast-dude.com/teams/beard-motorsports/">Beard Motorsports</a></li>
	<li class="page_item page-item-1740"><a href="http://diecast-dude.com/teams/b-j-mcleod-motorsports/">B.J. McLeod Motorsports</a></li>
	<li class="page_item page-item-1742"><a href="http://diecast-dude.com/teams/brandonbilt-motorsports/">Brandonbilt Motorsports</a></li>
	<li class="page_item page-item-1260"><a href="http://diecast-dude.com/teams/chip-ganassi-racing/">Chip Ganassi Racing</a></li>
	<li class="page_item page-item-1744"><a href="http://diecast-dude.com/teams/cr7-motorsports/">CR7 Motorsports</a></li>
	<li class="page_item page-item-1746"><a href="http://diecast-dude.com/teams/dgr-crosley-racing/">DGR-Crosley Racing</a></li>
	<li class="page_item page-item-1748"><a href="http://diecast-dude.com/teams/fdny-racing/">FDNY Racing</a></li>
	<li class="page_item page-item-217"><a href="http://diecast-dude.com/teams/front-row-motorsports/">Front Row Motorsports</a></li>
	<li class="page_item page-item-1750"><a href="http://diecast-dude.com/teams/gaunt-brothers-racing/">Gaunt Brothers Racing</a></li>
	<li class="page_item page-item-1752"><a href="http://diecast-dude.com/teams/germain-racing/">Germain Racing</a></li>
	<li class="page_item page-item-1755"><a href="http://diecast-dude.com/teams/gms-racing/">GMS Racing</a></li>
	<li class="page_item page-item-1758"><a href="http://diecast-dude.com/teams/go-fas-racing/">GO FAS Racing</a></li>
	<li class="page_item page-item-1760"><a href="http://diecast-dude.com/teams/go-green-racing/">Go Green Racing</a></li>
	<li class="page_item page-item-1762"><a href="http://diecast-dude.com/teams/h2-motorsports/">H2 Motorsports</a></li>
	<li class="page_item page-item-1764"><a href="http://diecast-dude.com/teams/halmar-friesen-motorsports/">Halmar-Friesen Motorsports</a></li>
	<li class="page_item page-item-1766"><a href="http://diecast-dude.com/teams/hattori-racing-enterprises/">Hattori Racing Enterprises</a></li>
	<li class="page_item page-item-1614"><a href="http://diecast-dude.com/teams/hendrick-motorsports/">Hendrick Motorsports</a></li>
	<li class="page_item page-item-1768"><a href="http://diecast-dude.com/teams/hill-motorsports/">Hill Motorsports</a></li>
	<li class="page_item page-item-1770"><a href="http://diecast-dude.com/teams/jd-motorsports/">JD Motorsports</a></li>
	<li class="page_item page-item-1772"><a href="http://diecast-dude.com/teams/jennifer-jo-cobb-racing/">Jennifer Jo Cobb Racing</a></li>
	<li class="page_item page-item-1774"><a href="http://diecast-dude.com/teams/jeremy-clements-racing/">Jeremy Clements Racing</a></li>
	<li class="page_item page-item-1776"><a href="http://diecast-dude.com/teams/jgl-racing/">JGL Racing</a></li>
	<li class="page_item page-item-1561"><a href="http://diecast-dude.com/teams/joe-gibbs-racing/">Joe Gibbs Racing</a></li>
	<li class="page_item page-item-1778"><a href="http://diecast-dude.com/teams/jordan-anderson-racing/">Jordan Anderson Racing</a></li>
	<li class="page_item page-item-1780"><a href="http://diecast-dude.com/teams/jtg-daugherty-racing/">JTG Daugherty Racing</a></li>
	<li class="page_item page-item-1782"><a href="http://diecast-dude.com/teams/jr-motorsports/">JR Motorsports</a></li>
	<li class="page_item page-item-1784"><a href="http://diecast-dude.com/teams/kaulig-racing/">Kaulig Racing</a></li>
	<li class="page_item page-item-1786"><a href="http://diecast-dude.com/teams/kyle-busch-motorsports/">Kyle Busch Motorsports</a></li>
	<li class="page_item page-item-1788"><a href="http://diecast-dude.com/teams/leavine-family-racing/">Leavine Family Racing</a></li>
	<li class="page_item page-item-1790"><a href="http://diecast-dude.com/teams/martins-motorsports/">Martins Motorsports</a></li>
	<li class="page_item page-item-1792"><a href="http://diecast-dude.com/teams/mbm-motorsports/">MBM Motorsports</a></li>
	<li class="page_item page-item-1794"><a href="http://diecast-dude.com/teams/mcanally-hilgemann-racing/">McAnally-Hilgemann Racing</a></li>
	<li class="page_item page-item-1796"><a href="http://diecast-dude.com/teams/means-motorsports/">Means Motorsports</a></li>
	<li class="page_item page-item-1798"><a href="http://diecast-dude.com/teams/nemco-motorsports/">NEMCO Motorsports</a></li>
	<li class="page_item page-item-1800"><a href="http://diecast-dude.com/teams/niece-motorsports/">Niece Motorsports</a></li>
	<li class="page_item page-item-1802"><a href="http://diecast-dude.com/teams/norm-benning-racing/">Norm Benning Racing</a></li>
	<li class="page_item page-item-1804"><a href="http://diecast-dude.com/teams/peck-motorsports/">Peck Motorsports</a></li>
	<li class="page_item page-item-1806"><a href="http://diecast-dude.com/teams/petty-ware-racing/">Petty Ware Racing</a></li>
	<li class="page_item page-item-1808"><a href="http://diecast-dude.com/teams/premium-motorsports/">Premium Motorsports</a></li>
	<li class="page_item page-item-1810"><a href="http://diecast-dude.com/teams/reaume-brothers-racing/">Reaume Brothers Racing</a></li>
	<li class="page_item page-item-1575"><a href="http://diecast-dude.com/teams/richard-childress-racing/">Richard Childress Racing</a></li>
	<li class="page_item page-item-1563"><a href="http://diecast-dude.com/teams/richard-petty-motorsports/">Richard Petty Motorsports</a></li>
	<li class="page_item page-item-1812"><a href="http://diecast-dude.com/teams/rick-ware-racing/">Rick Ware Racing</a></li>
	<li class="page_item page-item-1814"><a href="http://diecast-dude.com/teams/roper-racing/">Roper Racing</a></li>
	<li class="page_item page-item-1417"><a href="http://diecast-dude.com/teams/roush-fenway-racing/">Roush Fenway Racing</a></li>
	<li class="page_item page-item-1816"><a href="http://diecast-dude.com/teams/rss-racing/">RSS Racing</a></li>
	<li class="page_item page-item-1818"><a href="http://diecast-dude.com/teams/sam-hunt-racing/">Sam Hunt Racing</a></li>
	<li class="page_item page-item-1820"><a href="http://diecast-dude.com/teams/spire-motorsports/">Spire Motorsports</a></li>
	<li class="page_item page-item-1822"><a href="http://diecast-dude.com/teams/ss-green-light-racing/">SS Green Light Racing</a></li>
	<li class="page_item page-item-1824"><a href="http://diecast-dude.com/teams/starcom-racing/">StarCom Racing</a></li>
	<li class="page_item page-item-1844"><a href="http://diecast-dude.com/teams/stewart-haas-racing/">Stewart-Haas Racing</a></li>
	<li class="page_item page-item-229"><a href="http://diecast-dude.com/teams/team-penske/">Team Penske</a></li>
	<li class="page_item page-item-1826"><a href="http://diecast-dude.com/teams/thorsport-racing/">ThorSport Racing</a></li>
	<li class="page_item page-item-1828"><a href="http://diecast-dude.com/teams/wood-brothers-racing/">Wood Brothers Racing</a></li>
	<li class="page_item page-item-1830"><a href="http://diecast-dude.com/teams/youngs-motorsports/">Young&#8217;s Motorsports</a></li>
</ul>
</li>
<li class="page_item page-item-220 page_item_has_children"><a href="http://diecast-dude.com/tracks/">Tracks</a>
<ul class='children'>
	<li class="page_item page-item-231"><a href="http://diecast-dude.com/tracks/atlanta-motor-speedway/">Atlanta Motor Speedway</a></li>
	<li class="page_item page-item-233"><a href="http://diecast-dude.com/tracks/auto-club-speedway/">Auto Club Speedway</a></li>
	<li class="page_item page-item-235"><a href="http://diecast-dude.com/tracks/bristol-motor-speedway/">Bristol Motor Speedway</a></li>
	<li class="page_item page-item-222"><a href="http://diecast-dude.com/tracks/charlotte-motor-speedway/">Charlotte Motor Speedway</a></li>
	<li class="page_item page-item-237"><a href="http://diecast-dude.com/tracks/chicagoland-speedway/">Chicagoland Speedway</a></li>
	<li class="page_item page-item-239"><a href="http://diecast-dude.com/tracks/darlington-raceway/">Darlington Raceway</a></li>
	<li class="page_item page-item-241"><a href="http://diecast-dude.com/tracks/daytona-international-speedway/">Daytona International Speedway</a></li>
	<li class="page_item page-item-243"><a href="http://diecast-dude.com/tracks/dover-international-speedway/">Dover International Speedway</a></li>
	<li class="page_item page-item-245"><a href="http://diecast-dude.com/tracks/indianapolis-motor-speedway/">Indianapolis Motor Speedway</a></li>
	<li class="page_item page-item-247"><a href="http://diecast-dude.com/tracks/ism-phoenix-raceway/">ISM (Phoenix) Raceway</a></li>
	<li class="page_item page-item-252"><a href="http://diecast-dude.com/tracks/kansas-speedway/">Kansas Speedway</a></li>
	<li class="page_item page-item-254"><a href="http://diecast-dude.com/tracks/kentucky-speedway/">Kentucky Speedway</a></li>
	<li class="page_item page-item-256"><a href="http://diecast-dude.com/tracks/las-vegas-motor-speedway/">Las Vegas Motor Speedway</a></li>
	<li class="page_item page-item-258"><a href="http://diecast-dude.com/tracks/martinsville-speedway/">Martinsville Speedway</a></li>
	<li class="page_item page-item-260"><a href="http://diecast-dude.com/tracks/michigan-international-speedway/">Michigan International Speedway</a></li>
	<li class="page_item page-item-262"><a href="http://diecast-dude.com/tracks/new-hampshire-motor-speedway/">New Hampshire Motor Speedway</a></li>
	<li class="page_item page-item-264"><a href="http://diecast-dude.com/tracks/pocono-raceway/">Pocono Raceway</a></li>
	<li class="page_item page-item-294"><a href="http://diecast-dude.com/tracks/richmond-raceway/">Richmond Raceway</a></li>
	<li class="page_item page-item-266"><a href="http://diecast-dude.com/tracks/sonoma-raceway/">Sonoma Raceway</a></li>
	<li class="page_item page-item-271"><a href="http://diecast-dude.com/tracks/talladega-superspeedway/">Talladega Superspeedway</a></li>
	<li class="page_item page-item-276"><a href="http://diecast-dude.com/tracks/texas-motor-speedway/">Texas Motor Speedway</a></li>
	<li class="page_item page-item-278"><a href="http://diecast-dude.com/tracks/watkins-glen-international/">Watkins Glen International</a></li>
	<li class="page_item page-item-285"><a href="http://diecast-dude.com/tracks/iowa-speedway-xfinity-and-trucks-only/">Iowa Speedway (Xfinity and trucks only)</a></li>
	<li class="page_item page-item-287"><a href="http://diecast-dude.com/tracks/mid-ohio-sports-car-course-xfinity-only/">Mid-Ohio Sports Car Course (Xfinity only)</a></li>
	<li class="page_item page-item-289"><a href="http://diecast-dude.com/tracks/road-america-xfinity-only/">Road America (Xfinity only)</a></li>
	<li class="page_item page-item-296"><a href="http://diecast-dude.com/tracks/canadian-tire-motorsport-park-road-course-trucks-only/">Canadian Tire Motorsport Park (Road Course) (Trucks only)</a></li>
	<li class="page_item page-item-298"><a href="http://diecast-dude.com/tracks/eldora-speedway-trucks-only/">Eldora Speedway (Trucks only)</a></li>
	<li class="page_item page-item-300"><a href="http://diecast-dude.com/tracks/world-wide-technology-raceway-trucks-only/">World Wide Technology Raceway (Trucks only)</a></li>
</ul>
</li>
		</ul>
			</section><section id="search-2" class="widget widget_search">
<form role="search" method="get" class="search-form" action="http://diecast-dude.com/">
	<label>
		<span class="screen-reader-text">Search for:</span>
		<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
	</label>
	<button type="submit" class="search-submit"><span class="screen-reader-text">Search</span></button>
</form>
</section>		<section id="recent-posts-2" class="widget widget_recent_entries">		<h2 class="widget-title">Recent Posts</h2>		<ul>
											<li>
					<a href="http://diecast-dude.com/2020/02/21/kyle-busch-wins-a-truck-race-and-in-equally-surprising-news-water-is-still-wet/">Kyle Busch Wins A Truck Race (And In Equally Surprising News Water Is Still Wet)</a>
									</li>
											<li>
					<a href="http://diecast-dude.com/2020/02/19/photo-of-the-year/">Photo Of The Year</a>
									</li>
											<li>
					<a href="http://diecast-dude.com/2020/02/18/the-post-i-hope-i-never-have-to-write/" aria-current="page">The Post I Hope I Never Have To Write</a>
									</li>
											<li>
					<a href="http://diecast-dude.com/2020/02/14/of-all-the-times-to-be-sick/">Of All The Times To Be Sick &#8230;</a>
									</li>
											<li>
					<a href="http://diecast-dude.com/2020/02/12/kids-will-be-kids-or-who-cares-how-the-daytona-500-goes-were-going-to-walt-disney-world-right-now/">Kids Will Be Kids; Or, Who Cares How The Daytona 500 Goes &#8211; We&#8217;re Going To Walt Disney World RIGHT NOW!</a>
									</li>
					</ul>
		</section><section id="recent-comments-2" class="widget widget_recent_comments"><h2 class="widget-title">Recent Comments</h2><ul id="recentcomments"></ul></section><section id="archives-2" class="widget widget_archive"><h2 class="widget-title">Archives</h2>		<ul>
				<li><a href='http://diecast-dude.com/2020/02/'>February 2020</a></li>
	<li><a href='http://diecast-dude.com/2020/01/'>January 2020</a></li>
		</ul>
			</section><section id="categories-2" class="widget widget_categories"><h2 class="widget-title">Categories</h2>		<ul>
				<li class="cat-item cat-item-3"><a href="http://diecast-dude.com/category/nascar-cup-series/">NASCAR Cup Series</a>
</li>
	<li class="cat-item cat-item-2"><a href="http://diecast-dude.com/category/nascar-gander-rv-and-outdoors-truck-series/">NASCAR Gander RV &amp; Outdoors Truck Series</a>
</li>
	<li class="cat-item cat-item-46"><a href="http://diecast-dude.com/category/nascar-musings/">NASCAR Musings</a>
</li>
	<li class="cat-item cat-item-12"><a href="http://diecast-dude.com/category/nascar-news/">NASCAR News</a>
</li>
	<li class="cat-item cat-item-11"><a href="http://diecast-dude.com/category/site-news/">Site News</a>
</li>
	<li class="cat-item cat-item-5"><a href="http://diecast-dude.com/category/somewhat-out-of-alignment/">Somewhat Out of Alignment</a>
</li>
		</ul>
			</section><section id="meta-2" class="widget widget_meta"><h2 class="widget-title">Meta</h2>			<ul>
						<li><a href="http://diecast-dude.com/wp-login.php">Log in</a></li>
			<li><a href="http://diecast-dude.com/feed/">Entries feed</a></li>
			<li><a href="http://diecast-dude.com/comments/feed/">Comments feed</a></li>
			<li><a href="https://wordpress.org/">WordPress.org</a></li>			</ul>
			</section>	</aside><!-- .sidebar .widget-area -->

		</div><!-- .site-content -->

		<footer id="colophon" class="site-footer" role="contentinfo">
			
			
			<div class="site-info">
								<span class="site-title"><a href="http://diecast-dude.com/" rel="home">The Diecast Dude&#039;s (Mostly) NASCAR Blah Blah Blog</a></span>
								<a href="https://wordpress.org/" class="imprint">
					Proudly powered by WordPress				</a>
			</div><!-- .site-info -->
		</footer><!-- .site-footer -->
	</div><!-- .site-inner -->
</div><!-- .site -->

	<div style="display:none">
	<div class="grofile-hash-map-21a01650551218b55097c86f22e23160">
	</div>
	</div>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"http:\/\/diecast-dude.com\/2020\/02\/18\/the-post-i-hope-i-never-have-to-write\/":1929};
	</script>
				<script type='text/javascript' src='http://diecast-dude.com/wp-content/plugins/jetpack/_inc/build/photon/photon.min.js?ver=20191001'></script>
<script type='text/javascript' src='http://diecast-dude.com/wp-includes/js/jquery/ui/effect.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://diecast-dude.com/wp-includes/js/jquery/ui/effect-slide.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://diecast-dude.com/wp-includes/js/jquery/ui/effect-highlight.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://diecast-dude.com/wp-includes/js/jquery/ui/effect-fold.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://diecast-dude.com/wp-includes/js/jquery/ui/effect-blind.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://diecast-dude.com/wp-content/plugins/show-hidecollapse-expand/assets/js/bg-show-hide.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=2020Febaa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://diecast-dude.com/wp-content/plugins/jetpack/modules/wpgroho.js?ver=5.3.2'></script>
<script type='text/javascript' src='http://diecast-dude.com/wp-content/themes/twentysixteen/js/skip-link-focus-fix.js?ver=20160816'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var screenReaderText = {"expand":"expand child menu","collapse":"collapse child menu"};
/* ]]> */
</script>
<script type='text/javascript' src='http://diecast-dude.com/wp-content/themes/twentysixteen/js/functions.js?ver=20181230'></script>
<script type='text/javascript' src='http://diecast-dude.com/wp-includes/js/wp-embed.min.js?ver=5.3.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://diecast-dude.com/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=8.2.3'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
</script>
<script type='text/javascript' src='https://stats.wp.com/e-202009.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.2.3',blog:'102283004',post:'1929',tz:'-8',srv:'diecast-dude.com'} ]);
	_stq.push([ 'clickTrackerInit', '102283004', '1929' ]);
</script>
</body>
</html>
